Garbled characters occur after FineBI connects to the MySQL database

dxn010 注册会员
2023-02-26 18:27

What is your mysql version and database code?

crispenn 注册会员
2023-02-26 18:27

the reference answer GPT ᴼ ᴾ ᴱ ᴺ ᴬ ᴵ < br / > the Chinese led problem may be because the database encoding format and connections do not match the encoding format. You can try adding character set parameters to FineBI's connection string, such as:

jdbc:mysql://localhost:3306/dbname? useUnicode=true& characterEncoding=UTF-8

Where dbname is the name of the database you want to connect to. Change UTF-8 in the connection string to the encoding format of your database.

If the above methods do not solve the problem, you can try modifying the configuration of the encoding format in FineBI. The operations are as follows:

  1. Enter FineBI background management interface;
  2. Click "System Management" - "Global Parameters";
  3. Locate the MySQL data source you are connecting to in Data Sources;
  4. Click "Edit" and find the "Encoding" option in the "Advanced" TAB;
    Changes the encoding format to the one consistent with the database.