0
Follow
0
View

Ubuntu does not satisfy dependencies

dorothyzhang81 注册会员
2023-02-27 10:39

the reference answer GPT ᴼ ᴾ ᴱ ᴺ ᴬ ᴵ < br / > according to error messages, The python3-distutils package you are trying to install relies on an older Python version(less than 3.9), but you already have Python 3.10.6 installed on your system. This can lead to dependency conflicts.

To solve this problem, try the following steps:

1. Verify that python3 is installed on your system:
$ sudo apt-get update
$ sudo apt-get install python3


2. Verify that python3-distutils and python3-lib2to3 are installed on your system:
$ sudo apt-get install python3-distutils python3-lib2to3


3. If the previous steps do not resolve the problem, try manually installing an older Python version and using it to install python3-distutils:

$ sudo apt-get install python3.8
$ sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.8 1
$ sudo update-alternatives --config python3


Then select Python 3.8 as the default version and try to reinstall python3-distutils:

$ sudo apt-get install python3-distutils


wurb1975 注册会员
2023-02-27 10:39

I am Ubuntu in win+vmvare, this machine has python and conda environment, but it will not affect it

fyb3526642 注册会员
2023-02-27 10:39

Ubuntu has python3 by default, you run python --version

edward840906 注册会员
2023-02-27 10:39

Some versions of Ubuntu come with python. You can refer to this blog for built-in python < br / > < a href = "https://blog.csdn.net/wokaowokaowokao12345/article/details/127095052" target="_blank"> https://blog.csdn.net/wokaowokaowokao12345/article/details/127095052