Error: Ensure condition failed: VendorId! Error: Ensure condition failed: Vendorid! = EGpuVendorId::Unknown

cica1987 注册会员
2023-02-28 12:31

This answer quotes ChatGPT

This error may be caused by VulkanRHI(Vulkan rendering interface) not detecting the correct GPU vendor information.

You can try the following solution:

1. Update the GPU driver and recompile UE4.

2. If your GPU vendor is not a mainstream one(such as Nvidia, AMD, or Intel), you may need to manually specify the GPU vendor information. On line 182 of the VulkanDevice.cpp file, check that VendorId is correctly set to your GPU vendor ID. You can try setting the VendorId manually, such as EGpuVendorId::ARM or EGpuVendorId::Qualcomm equivalent.